Swiftpack.co - Package - pubnub/swift

PubNub Swift SDK

Platform CocoaPods Compatible Swift Package Manager compatible Carthage Compatible Build Status Codacy Coverage Grade Badge Codacy Badge

Requirements

  • iOS 8.0+ / macOS 10.10+ / Mac Catalyst 13.0+ / tvOS 9.0+ / watchOS 2.0+
  • Xcode 11+
  • Swift 5+

Installation

The PubNub Swift SDK doesn't contain any external dependencies.

CocoaPods

# Podfile
use_frameworks!

target 'YOUR_TARGET_NAME' do
  pod 'PubNubSwift', '~> 2.0'
end

Note: Replace YOUR_TARGET_NAME with your target's name.

In the directory containing your Podfile. execute the following:

pod install

Carthage

Officially supported: Carthage 0.33 and up.

Add this to Cartfile

github "pubnub/swift" ~> 2.0

Then in the directory containing your Cartfile, execute the following:

carthage update

Swift Package Manager

  • Create or open your project inside of Xcode
  • Select File -> Swift Packages -> Add Package Dependency...
  • Search for PubNub and select the swift package owned by pubnub, and hit the Next button
  • Use the Up to Next Major Version rule spanning from 2.0.0 < 3.0.0, and hit the Next button

For more information see Apple's guide on Adding Package Dependencies to Your App

Documentation

Check out our official docs page.

Communication

If you need help or have a general question, contact support

License

The PubNub Swift SDK is released under the MIT license. See LICENSE for details.

Github

link
Stars: 0
Help us keep the lights on

Dependencies