Swiftpack.co - toddkramer/LocalizedTimeAgo as Swift Package

Swiftpack.co is a collection of thousands of indexed Swift packages. Search packages.
See all packages published by toddkramer.
toddkramer/LocalizedTimeAgo 1.3.0
Swift time ago framework localized in 42 languages.
⭐️ 33
🕓 2 days ago
.package(url: "https://github.com/toddkramer/LocalizedTimeAgo.git", from: "1.3.0")

LocalizedTimeAgo

CocoaPods Version Swift Platform Swift Package Manager compatible Carthage compatible

LocalizedTimeAgo is a time ago framework written in Swift and localized in 42 languages. It uses translations from the popular Objective-C library DateTools.

Supported Localizations

Amharic, Arabic, Basque, Bulgarian, Catalan, Chinese (Simplified), Chinese (Traditional), Croatian, Czech, Danish, Dutch, English, Finnish, French, German, Greek, Gujarati, Hebrew, Hindi, Hungarian, Icelandic, Indonesian, Italian, Japanese, Korean, Latvian, Malay, Norwegian, Polish, Portuguese (Brazil), Portuguese (Portugal), Romanian, Russian, Slovak, Slovenian, Spanish, Swedish, Thai, Turkish, Ukranian, Vietnamese, Welsh

Installation

Swift Package Manager

Swift Package Manager is Apple's official package manager for Swift frameworks. To install with Swift Package Manager:

  1. Add LocalizedTimeAgo to your Package.swift file:

    import PackageDescription
    
    let package = Package(
        name: "MyAppTarget",
        dependencies: [
            .Package(url: "https://github.com/toddkramer/LocalizedTimeAgo",
                     majorVersion: 1, minor: 3)
        ]
    )
    
  2. Run swift build.

  3. Generate Xcode project:

    swift package generate-xcodeproj
    

Carthage

Carthage is a decentralized dependency manager for Cocoa projects. To install LocalizedTimeAgo with Carthage:

  1. Make sure Carthage is installed.

  2. Add LocalizedTimeAgo to your Cartfile:

    github "toddkramer/LocalizedTimeAgo" ~> 1.3.0
    
  3. Run carthage update and add the appropriate framework.

CocoaPods

CocoaPods is a centralized dependency manager for Cocoa projects. To install LocalizedTimeAgo with CocoaPods:

  1. Make sure the latest version of CocoaPods is installed.

  2. Add LocalizedTimeAgo to your Podfile:

    use_frameworks!
    
    pod 'LocalizedTimeAgo', '~> 1.3.0'
    
  3. Run pod install.

GitHub

link
Stars: 33
Last commit: 2 days ago
jonrohan Something's broken? Yell at me @ptrpavlik. Praise and feedback (and money) is also welcome.

Swiftpack is being maintained by Petr Pavlik | @ptrpavlik | @swiftpackco | API | Analytics