Swiftpack.co - Package - jwd-ali/JDTabBarController

JDTabBarController

CI Status CocoaPods Version Carthage Compatible License Platform Swift 5.1

JDTabBarController is Light way to add Fancy bottom bar which gives you Simple Animated tab Bar with native control.




Requirements

  • iOS 10.0+ / Mac OS X 10.9+ / watchOS 2.0+ / tvOS 9.0+
  • Xcode 8.0+

Installation

CocoaPods

To integrate JDTabBarController into your Xcode project using CocoaPods, specify it in your Podfile:

use_frameworks!

pod 'JDTabBarController'

Then, run the following command:

$ pod install

Carthage

To integrate JDTabBarController into your Xcode project using Carthage, specify it in your Cartfile:

github "jwd-ali/JDTabBarController"

Swift Package Manager (SPM)

Prerequisites

  • OSX

Update Package.swift

To integrate JDTabBarController in your project, add the proper description to your Package.swift file:

// swift-tools-version:5.0
import PackageDescription

let package = Package(
    name: "YOUR_PROJECT_NAME",
    dependencies: [
        .package(url: "https://github.com/jwd-ali/JDTabBarController.git")
    ],
    targets: [
        .target(
            name: "YOUR_TARGET_NAME",
            dependencies: ["JDTabBarController"]
        ),
        ...
    ]
)

Manually

If you prefer not to use a dependency manager, you can integrate JDTabBarController into your project manually.

  • Add sources into your project:
    • Drag Sources

Contributing

I’d love to have help on this project. For small changes please open a pull request, for larger changes please open an issue first to discuss what you’d like to see.

License

JDTabBarController is under MIT. See LICENSE file for more info.

Github

link
Stars: 17

Dependencies

Used By

Total: 0