Swiftpack.co - Package - ivoronin/ArchiveMounter

Logo

Archive Mounter

Archive Mounter is a macOS application allowing to mount archive files as disk images.
It currently supports ZIP and RAR archives.

Travis

Screenshots

Main window

Manage volumes window

Requirements

:exclamation:You should download and install latest version of FUSE for macOS before using this application.

Download

Latest stable release

Usage

You can run app directly and choose an archive to mount or use it from Finder's Open With context menu.
It is also possible to use Archive Mounter as a default app for opening archives (see Apple KB article).

Q & A

Build requirements

  • Xcode (>= 10.0)
  • FUSE for macOS
  • autoconf
  • automake
  • cmake
  • mercurial
  • pkg-config
  • python@3
  • swiftlint (>= 0.33)
  • npm

System headers need to be present in /usr/include (install /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg if needed)

Github

link
Stars: 47
Help us keep the lights on

Dependencies

Used By

Total: 0

Releases

v1.5.0 - Jul 3, 2019

  • Support for jar files
  • Fixed #5
  • Updated external components to latest stable versions
  • Code refinement

v1.4.2 - Jan 8, 2019

  • Fixed support for old macOS versions (10.10+)
  • Updated external components to latest stable versions

v1.4.0 - May 19, 2018

  • Switch to unrar 5.6.4
  • Display default volume name

v1.3.1 - May 1, 2018

  • Fixed handling of filenames and options containing commas
  • Singed release binaries

v1.3.0 - Apr 30, 2018

  • Added UI for managing mounted volumes (open in Finder, unmount, unmount all)
  • Updated external components to latest versions
  • Compatibility with older macOS versions (10.10+) #1