Swiftpack.co - Package - eBardX/XestiNotify

XestiNotify

Swift 4.x License Platform

Build Status Code Coverage Documented

CocoaPods Carthage Swift Package Manager

Overview

The XestiNotify framework provides ...

Reference Documentation

Full reference documentation is available courtesy of Jazzy.

Requirements

  • iOS 8.0+ / macOS 10.10+ / tvOS 9.0+ / watchOS 2.0+
  • Xcode 9.0+
  • Swift 4.0+

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

To integrate XestiNotify into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

target '<Your Target Name>' do
    pod 'XestiNotify'
end

Then, run the following command:

$ pod install

Carthage

Carthage is a decentralized dependency manager that builds your dependencies and provides you with binary frameworks.

You can install Carthage with Homebrew using the following commands:

$ brew update
$ brew install carthage

To integrate XestiNotify into your Xcode project using Carthage, specify it in your Cartfile:

github "eBardX/XestiNotify"

Then, run the following command:

$ carthage update

Finally, drag the built XestiNotify.framework into your Xcode project.

Swift Package Manager

The Swift Package Manager (SPM) is a tool for automating the distribution of Swift code and is integrated into the swift compiler. It does not yet support all platforms, but you can install XestiNotify on platforms that SPM does support.

Once you have your Swift package set up, adding XestiNotify as a dependency is as easy as adding it to the dependencies value of your Package.swift.

dependencies: [
    .package(url: "https://github.com/eBardX/XestiNotify.git", from: "0.1.0")
]

Usage

Credits

J. G. Pusey (ebardx@gmail.com)

License

XestiNotify is available under the MIT license.

Github

link
Stars: 0
Help us keep the lights on

Dependencies

Used By

Total: