Swiftpack.co - Package - d4l-data4life/d4l-utils-ios

Swiftpack.co is a collection of thousands of indexed Swift packages. Search packages.

d4l-data4life/d4l-utils-ios

Data4Life collection of utilities for swift code

d4l-util-ios

Utilities library for iOS SDK projects

CocoaPods Compatible Carthage Compatible Swift Package Manager compatible License

Usage

Requirements

  • Xcode 12.0+
  • iOS 12.0+
  • Swift 5.3+

Management

SDK is handled by Fastlane and all of the available functions are available in the README.

Installation

CocoaPods

To install with CocoaPods add the following line to the podfile.

pod 'Data4LifeSDKUtils', '~> 0.3.0'

Carthage

To install with Carthage add the following line to the Cartfile:

github "d4l-data4life/d4l-utils-ios"

Run carthage to build the framework and drag the built Data4LifeSDK.framework into your Xcode project. Follow build instructions.

Swift Package Manager

To install with Swift Package Manager add this package as a dependency in Package.swift:

.package(url: "https://github.com/d4l-data4life/d4l-utils-ios.git", .upToNextMinor(from: "0.3.0"))

Building

Install Fastlane and other dependencies using Bundler

bundle install

Note: Check official page for info on how to install Bundler.

Install Carthage

brew install carthage

Note: For other installation methods check README.

Build frameworks

Note: Since from XCode 12 Carthage packaging does not work anymore, please use the script.

./wcarthage.sh bootstrap --platform iOS

Github

link
Stars: 0
Last commit: 5 days ago

Releases

0.3.0 - 2020-12-01T14:04:53

changelog