Swiftpack.co - Package -

admob_flutter

Build Status version version GitHub stars GitHub forks GitHub issues

Demo

A new Flutter plugin that uses native platform views to show Admob banner ads!

This plugin also has support for Interstitial and Reward ads.

Installation

  1. Depend on it Add this to your package's pubspec.yaml file:
dependencies:
  admob_flutter: "^0.3.3"

  1. Install it You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

  1. Import it Now in your Dart code, you can use:
import 'package:admob_flutter/admob_flutter.dart';

Supported Platforms

  • 0.3.0 >= iOS
  • 0.2.0 >= AndroidX
  • FlutterSdk >=2.1.0 < 3.0.0

Supported Admob features

  • Banner Ads
  • Interstitial Ads
  • Reward Ads
  • Native Ads (Coming soon)

View the rest of the documentation on the repository Wiki!

Pull Requests

I welcome and encourage all pull requests. Here are some basic rules to follow to ensure timely addition of your request:

  1. Match the document style as closely as possible.
  2. Please keep PR titles easy to read and descriptive of changes, this will make them easier to review/merge.
  3. Pull requests must be made against master branch for this repository.
  4. Check for existing issues first, before filing an issue.
  5. Have fun!

Github

link
Stars:
Help us keep the lights on

Dependencies

Used By

Total: 0