Swiftpack.co - Package - PL-Swift/CPLSwift


PostgreSQL Swift3 Swift4 macOS tuxOS

A Swift system library package (C wrapper) for PostgreSQL server extensions. This package is part of the PL/Swift effort.

Using the Package

Important: This version of the package requires that you install plswift. It installs the necessary shims.

Setup your Package.swift to include CPLSwift:

import PackageDescription

let package = Package(
  name: "MyTool",
  dependencies: [
    .Package(url: "git@github.com:PL-Swift/CPLSwift.git", majorVersion: 0),

Import the CPLSwift module.

import CPLSwift


PL/Swift is brought to you by ZeeZide. We like feedback, GitHub stars, cool contract work, presumably any form of praise you can think of.


Stars: 0
Help us keep the lights on


Used By

Total: 1