Swiftpack.co - Package - KatalysatorAB/glimr-ios-lite

GLGeoRealtime Readme

Usage

For documentation visit http://developer.glimr.io

Installation with CocoaPods

CocoaPods is a dependency manager for Objective-C, which automates and simplifies the process of using 3rd-party libraries like GLGeoRealtime in your projects. The latest release with adjustments for iOS 14 is 3.1.1.

Podfile

platform :ios, '9.0'
pod "GLGeoRealtime"

Github

link
Stars: 0

Dependencies

Used By

Total: 0

Releases

static libs wrapped in xcframework for SPM - 2020-10-22 06:20:24

the SDK is now available as xcframework which can be consumed using the Swift Package Manager. for performance reasons the library was migrated from a dynamically linked framework to static libraries.

add xcframework support - 2020-10-12 12:57:58

the SDK is now available as xcframework which can be consumed using the Swift Package Manager.

revert xcframework migration - 2020-09-21 10:06:05

revert xcframework migration due to issues with cocoapods & SwiftPM

revert iOS 14 IDFA tracking adjustments - 2020-09-06 13:21:05

iOS 14 adjustments - 2020-09-01 17:48:41

  • iOS 14 change for IDFA tracking. Enable tracking permission request via SDK
  • iOS 14 adjustment for location permission
  • Migrate to XCFramework

Remove last CoreBluetooth occurrence - 2020-03-23 11:14:26

Remove last CoreBluetooth occurrence

Added assert to notify the host app if glimrTagsWithCompletion is not called on the main thread - 2019-12-11 08:56:45

Added assert to notify the host app if glimrTagsWithCompletion is not called on the main thread

Bugfix release - 2019-12-04 18:25:33

fix issue that caused network calls to happen on main thread and blocking app on startup leading to a crash

Bitcode support for CocoaPods - 2019-09-09 11:16:26

Added custom override method for replacing IDFA - 2019-08-06 11:12:57

Added custom override method for replacing IDFA

Fix POST payload, include all data points as in 3.0.0 - 2019-05-20 20:52:20

fixes an issue that data wasn't assigned to the correct app identifier introduced in 3.0.1. we recommend updating to 3.0.2.

Raise initial version to 3.0.0 - 2018-04-09 12:19:11

Raise initial version to 3.0.0 to have a clean start and match Android SDK

Initial Release - 2018-04-06 11:06:53

This is the first lite (focussed on realtime geo) release of our Glimr SDK. Please let us know if you encounter issues with CocoaPods or app store submission