Swiftpack.co - Package - 4taras4/CountryCode

CountryPicker

Swift Package Manager compatible Build Status Platform Swift version Swift version Beerpay

Picker code Swift 3 / 4.

Example

To run the example project, clone the repo, and run pod install from the Example directory first. 1

Usage

Make your UIPickerView a class of CountryPicker, set its countryPickerDelegate and implement its countryPhoneCodePicker method. Example:

import CountryPicker

class ViewController: UIViewController, CountryPickerDelegate {

    @IBOutlet weak var picker: CountryPicker!
   
    
    override func viewDidLoad() {
        super.viewDidLoad()
       //get current country
        let locale = Locale.current
        let code = (locale as NSLocale).object(forKey: NSLocale.Key.countryCode) as! String?
        //init Picker
        picker.displayOnlyCountriesWithCodes = ["DK", "SE", "NO", "DE"] //display only
        picker.exeptCountriesWithCodes = ["RU"] //exept country
        let theme = CountryViewTheme(countryCodeTextColor: .white, countryNameTextColor: .white, rowBackgroundColor: .black, showFlagsBorder: false)        //optional for UIPickerView theme changes
        picker.theme = theme //optional for UIPickerView theme changes
        picker.countryPickerDelegate = self
        picker.showPhoneNumbers = true
        picker.setCountry(code!)

    }
    
    // a picker item was selected
    func countryPhoneCodePicker(_ picker: CountryPicker, didSelectCountryWithName name: String, countryCode: String, phoneCode: String, flag: UIImage) {
       //pick up anythink
      code.text = phoneCode
    }

}

Integration

CocoaPods (iOS 8+, OS X 10.9+)

CountryPicker is available through CocoaPods. To install

Swift 3.1 (Xcode 9) pod 'CountryPickerSwift', '1.7'

Swift 3.0+ (Xcode 8) pod 'CountryPickerSwift', '1.4.4'

it, simply add the following line to your 'Podfile':

platform :ios, '8.0'
use_frameworks!

target 'MyApp' do
    pod 'CountryPickerSwift'
end

Swift Package Manager

You can use The Swift Package Manager to install CountryPicker by adding the proper description to your Package.swift file:

import PackageDescription

let package = Package(
    name: "YOUR_PROJECT_NAME",
    targets: [],
    dependencies: [
        .Package(url: "git@github.com:4taras4/CountryCode.git")
    ]
)

Note that the Swift Package Manager is still in early design and development, for more information checkout its GitHub Page

Manually

To use this library in your project manually just drag and drop CountryPicker folder to your project.

Author

4taras4, 4taras4@gmail.com

License

CountryPicker is available under the MIT license. See the LICENSE file for more info. release-link

Donate

Donation Bitcoin 141Q3KduSqvTtMbrU6YouSErDBh1SpiLrL

Support on Beerpay

Hey dude! Help me out for a couple of :beers:!

Beerpay Beerpay

Github

link
Stars: 101
Help us keep the lights on

Dependencies

Releases

1.7.1 - Mar 16, 2018

Now you can customize your picker theme

1.4.5 - Sep 26, 2017

1.4.4 - Aug 13, 2017

1.4.1 - Mar 29, 2017

Could not load the "se" image referenced from a nib in the bundle with identifier "org.cocoapods.CountryPicker"

1.4.0 - Feb 10, 2017