Swiftpack.co - Package - 0xxd0/Inspector

Inspector Circle CI

Travis CI

An elegant Object-Oriented objc runtime wrapper for Swift.

Requirement

platform language Swift Version GitHub code size in bytes

Required

  • Xcode 9.0+
  • iOS 8.0+ | macOS 10.9+ | tvOS 9.0+ | watchOS 2.0+
  • Swift 3.2+

Optional

  • CocoaPods 1.3+

Installation

CocoaPods

CocoaPods

CocoaPods CocoaPods is a dependency manager for Swift and Objective-C Cocoa projects. It has over 41 thousand libraries and is used in over 3 million apps. CocoaPods can help you scale your projects elegantly.

Install Cocoapods

$ gem install cocoapods

Integrate Inspector

With CocoaPods, specify Inspector in your Podfile:

source 'https://github.com/CocoaPods/Specs.git'
platform :ios, '8.0'
use_frameworks!

target '<Your Target>' do
    pod 'Inspector', '~> 0.0.1'
end

run pod install:

$ pod install

Carthage

Carthage is intended to be the simplest way to add frameworks to your Cocoa application.

Install Carthage

$ brew update
$ brew install carthage

Integrate Inspector

Add following to Cartfile:

github "0xxd0/Inspector" ~> 0.0.1

Swift Package Manager

The Swift Package Manager is a tool for managing the distribution of Swift code. It’s integrated with the Swift build system to automate the process of downloading, compiling, and linking dependencies.

Integrate Inspector

// Package.swift
// swift-tools-version:3.0

let package = Package(
    name: "<#Your Target#>",
    dependencies: [
        // ···
        .Package(url: "https://github.com/0xxd0/Inspector.git", majorVersion: 0)
        // ···
    ]
)

Manually

Download zip or clone repo and integrate into your project manually.

Document

See Online Documentation

License

license

This project is released under the MIT License.

Github

link
Stars: 2
Help us keep the lights on

Dependencies

Used By

Total: 0